v_merge Error and unexpected line in model

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

v_merge Error and unexpected line in model

randress
Using FEATool geometric construction tools I created a block (B1) containing two connected cylinders, one (C2) cylinder's base is wholly within the base of the other (C1) larger Cylinder:



The default Grid parameters were used to construct the mesh. A Voltage difference was placed on opposite ends of the block with J=0 for other external boundaries.  All internal boundaries are set to "Continuity". Upon solving and plotting (3D) the result, an unexpected line shows up in the model:

"

...and an error window "v_merge = 25   344" pops up:



The Post-->Slice Plot, 2D projection shows the same unexpected line, but does not bring up the error.



Here is the .fea model file.

cylinders_in_box.fea

What seems to have gone wrong?

-Randal


Reply | Threaded
Open this post in threaded view
|

Re: v_merge Error and unexpected line in model

Precise Simulation
Administrator
Thank you for the issue report.

randress wrote
...and an error window "v_merge = 25   344" pops up:
I apparently missed terminating a line with a semicolon to suppress output. This is not a "real" error and the algorithm works as intended. I will release an update addressing this in the future.

randress wrote
The Post-->Slice Plot, 2D projection shows the same unexpected line, but does not bring up the error.
As I've mentioned before:

Precise Simulation wrote
Note, however there may sometimes be small contour or boundary
segments present which are due to the mesh slicing procedure that is
not perfect (even a very nice 3D mesh can produce a quite terrible 2D
mesh slice with sliver and low quality mesh cells).
I will try to have a further look at it and see what I can do when I get some time. You can possibly try to shift the slice "up"/"down" and see if it can help makeing a better slice.
Reply | Threaded
Open this post in threaded view
|

Re: v_merge Error and unexpected line in model

randress
This post was updated on .
Precise Simulation wrote
I apparently missed terminating a line with a semicolon to suppress output. This is not a "real" error and the algorithm works as intended. I will release an update addressing this in the future.
:-)

Precise Simulation wrote
As I've mentioned before:
Precise Simulation wrote
Note, however there may sometimes be small contour or boundary
segments present which are due to the mesh slicing procedure that is
not perfect (even a very nice 3D mesh can produce a quite terrible 2D
mesh slice with sliver and low quality mesh cells).
I will try to have a further look at it and see what I can do when I get some time. You can possibly try to shift the slice "up"/"down" and see if it can help makeing a better slice.
Right. I remember now. I really don't mind a stray line or two so long as the solution and post-processing analysis is valid.

[Edited by RAndress]
**** Build 157 ****
It looks like the spurious line is gone.  I assume you found the "some time" and the fix!

Thanks for the update!

Kind regards,
Randal