"postplot" function gets error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

"postplot" function gets error

randress
Included below is a solved, post processed model file:

isoplot_example.fea

After exporting the fea object to Matlab via the file menu option, the following script was executed four times with the sets of parameters indicated below. Note that the only variation is the location of the cut-plane:

isolineslice.m

>> isolineslice (fea, "V", "XY", 0.49998 , 20, "jet")
>> isolineslice (fea, "V", "XY", 0.52001 , 20, "jet")
>> isolineslice (fea, "V", "XY", 0.52000 , 20, "jet")
>> isolineslice (fea, "V", "XY", 0.49999 , 20, "jet")

The first two succeeded producing the expected plots (3d then 2d), however the second two failed to produce a 2d plot and gave the error indications in the Matlab command window as seen in the following file:

isolines_console_msgs.txt

The failing call from the script was in both cases the call to "postplot" at line 118.

If you cannot reproduce this, please let me know and I will work on it further to get a reproducer (or find my problem :-)

Kind regards,
Randal

Reply | Threaded
Open this post in threaded view
|

Re: "postplot" function gets error

Precise Simulation
Administrator
Thank you for the issue report and clear test cases to reproduce them. I have issued a fix in build 20.05.134. Note, however there may sometimes be small contour or boundary segments present which are due to the mesh slicing procedure that is not perfect (even a very nice 3D mesh can produce a quite terrible 2D mesh slice with sliver and low quality mesh cells), I will try to look at that when I get the chance.
Reply | Threaded
Open this post in threaded view
|

Re: "postplot" function gets error

randress
Precise Simulation wrote
Thank you for the issue report and clear test cases to reproduce them.
You are quite welcome.  I may have mentioned that I retired from software eng.  I know the value of a good test-case :-)

Precise Simulation wrote
I have issued a fix in build 20.05.134.
Thanks for the fix!  And thanks again for the script that allows me to get the contours.

Precise Simulation wrote
Note, however there may sometimes be small contour or boundary segments present which are due to the mesh slicing procedure that is not perfect (even a very nice 3D mesh can produce a quite terrible 2D mesh slice with sliver and low quality mesh cells), I will try to look at that when I get the chance.
I will and anything further you can do is greatly appreciated ... maybe it will help toward implementing planar contours from the GUI in 3D.

Kind regards,
Randal