"Reset View" requires refresh of "Axis/Grid Settings"

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

"Reset View" requires refresh of "Axis/Grid Settings"

randress
After viewing a double chamfered, extruded ellipse (created in 2D Workspace) with manually customized azis extents (Axis/Grid Settings):



...when I select "Restore View" from context menu (right click), the object disappears from view:



However, if I select "Axis/Grid Settings" and select "Apply" the object returns to view:



================ second case with gui and model files ==================



...when I select "Restore View" from context menu (right click), the object is only partially shown:



However, if I select "Axis/Grid Settings" and select "Apply" the object returns to full view:



resetAxis.fea

The following .fes file goes beyond the creation of this issue but I failed to save the .fes that coincides with this case. I figured you could look at it and make the appropriate modifications.

resetAxisPlusMore.fes

resetAxis.m

Kind regards,
Randal

Reply | Threaded
Open this post in threaded view
|

Re: "Reset View" requires refresh of "Axis/Grid Settings"

Precise Simulation
Administrator
Thanks for the report but I can't really do much about the context menus and clipped views, as that's Matlab/Mathworks internal stuff. For the 2.0 release my plan is to replace the GUI backend as Matlabs ui toolkit just isn't performant enough (especially for large 3D models), so I really don't want to spend much time trying to fix their toolkit (as they also just seem to be making it slower and slower with each release).
Reply | Threaded
Open this post in threaded view
|

Re: "Reset View" requires refresh of "Axis/Grid Settings"

randress
Precise Simulation wrote
Thanks for the report but I can't really do much about the context menus and clipped views, as that's Matlab/Mathworks internal stuff...
Understood.

-Randal