Simple Test Case - OpenFOAM Error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Simple Test Case - OpenFOAM Error

pzach01
Operating system: Ubuntu 20.04
OpenFOAM version 9 (bashrc updated, verified working)

Steps to reproduce:
File -> New Model -> Model Examples and Tutorials -> Fluid Dynamics -> Turbulent Flow Over a Backwards Facing Step
OpenFOAM Error: Could not read velocity solution. Check OpenFOAM log file for convergence.



Any help would be greatly appreciated.
Thanks,
Peter

Reply | Threaded
Open this post in threaded view
|

Re: Simple Test Case - OpenFOAM Error

Precise Simulation
Administrator
This post was updated on .
Unfortunately, there is not enough information to say what could be wrong. OpenFOAM has not returned a solution for some reason, there is something in your system setup preventing OpenFOAM from running normally when using the toolbox.

Also you can try using the another OpenFOAM distribution as they can have been built differently (https://www.openfoam.com or https://www.openfoam.org).
Reply | Threaded
Open this post in threaded view
|

Re: Simple Test Case - OpenFOAM Error

Bagorats
In reply to this post by pzach01
Did you ever resolve this?   I'm getting the same error in a fresh install.
Reply | Threaded
Open this post in threaded view
|

Re: Simple Test Case - OpenFOAM Error

Bagorats
The issue occurs when you install OpenFoam per instructions.  The instructions for the SU2 Solver direct you to install MPI V10.  Apparently it's assumed that OpenFoam contains MPI V10 but you really need to install it from the Microsoft website.  This resolves the error.
Reply | Threaded
Open this post in threaded view
|

Re: Simple Test Case - OpenFOAM Error

Precise Simulation
Administrator
Bagorats wrote
The issue occurs when you install OpenFoam per instructions.  The instructions for the SU2 Solver direct you to install MPI V10.  Apparently it's assumed that OpenFoam contains MPI V10 but you really need to install it from the Microsoft website.  This resolves the error.
Thank you for confirming the issue, and that installing MPI V10 separately helps. It is not quite clear yet why a separate MPI install is necessary, as OpenFOAM typically comes with its own, the OpenFOAM instructions will be updated once this is clear.