OpenFOAM solver change to v.7

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenFOAM solver change to v.7

hcchen2u
Hi,

My version of Openfoam is v.7. How can I change the setting in FEATool in order to use OpenFOAM solver?

I receive this message as follow:


Thank you very much~
H-C
Reply | Threaded
Open this post in threaded view
|

Re: OpenFOAM solver change to v.7

Precise Simulation
Administrator
As the FEATool OpenFOAM interface has been designed, tested, and validated for OpenFOAM version 5 on Linux systems, FEATool will first look for an OpenFOAM installation and directory in "/opt/openfoam5", next it looks to see if a "FOAM_APP" enviroment variable is set.

In your case neither seems to be the case, so you could either try to:

1) Make sure the FOAM_APP variable is set to the directory of your OpenFOAM installation

2) Make a symbolic link from "/opt/openfoam5" to the directory of your OpenFOAM installation

3) Install OpenFOAM version 5 in parallel any other versions
Reply | Threaded
Open this post in threaded view
|

Re: OpenFOAM solver change to v.7

hcchen2u
Thank you very much.
It seems to me a proper choice is to install OpenFoam version 5.
H-C