Missing "Rotate 3D" icon

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing "Rotate 3D" icon

randress
This post was updated on .
[Oct 17, 2020: I have discovered that this issue ('"Missing "Rotate 3D") and the one posted as ' "gmsh" returns 2D result for 3D model' are indistinguishable (at least by me). See http://forum.featool.com/gmsh-returns-2D-result-for-3D-model-tp840.html for further explanation and a reproduce-able example.]

[v1p13b3]

While experimenting with the Chamfer function (chamfer on an already chamfered object) I encountered the following FEATool main gui window with a missing "Rotate 3D" icon.

 

Here is the model file:
twiceChamferedExtrudedEllipse.fea

If I am able to generate this from scratch, I will post a reply to this post.

Kind regards,
Randal

BTW, I am very much enjoying the enhanced "undo".  I like being able to delete an object while I work with another in the model and then go back and restore it (as the last object deleted).  And I am also using repeated undo (undo->undo->undo) to go back and try different things. I am not quite sure just what all is different about the change in this version, but I like it.

=================================================================
========== additional example below added 14 Oct 2020 ===========
=================================================================

I found another model file that exhibits this same characteristic (missing "3D Rotate"):

LargebladeInTank.fea

...which looks like this:



Sorry I have no other files or information on how to reproduce it.
-Randal
Reply | Threaded
Open this post in threaded view
|

Re: Missing "Rotate 3D" icon

randress
I could not re-create this issue.  But I can create a similar model - double chamfered (.005 & .0015), extruded (.02) 2D ellipse (.1 x .05), shrunk in the Z dimension (.05), inside a box.



Here is a MATLAB script that can be used to create it. The sphere created at beginning must be deleted manually after script runs. (Note that within the script, I have commented out the section of code that was generated to delete S1. The function "geom_update_tags" will not run from the MATLAB environment.):

createDblChmfEllipsoidInBlk.m

The ellipse-ish model alone will support a grid gen:



But when I put a box around it, the grid gen fails:



I would not have been surprised if the grid gen of the double chamfered Ellipsoidish object had failed.  I seem to recall something about fillet on top of an already fillet'ed object would cause problems.  But it only failed when I put a box around it.

If this should be a separate post, please split it off to create one.

Kind regards,
Randal

BTW, what I am trying to do (practically) is to create an elliptical shaped propeller blade. I want to use fillet and/or chamfer to "sharpen" the edges.