FEATool won't solve

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

FEATool won't solve

jhelffrich
I first tried one of the FSI examples of fluid flow called "Flow in a driven cavity" that gave an error while running through the script.  When I click the Solve button, nothing happens but I get a warning in the Matlab UI saying "Warning: No or incompatible solution found. Applying initial conditions.
Error using featool
Could not find unique uicontrol with identifier button_post_settings
Caused by:
    Error executing UI action:
    ["uicontrol","button_post_settings",{},"Callback",{}]
Error while evaluating DestroyedObject Callback."
Reply | Threaded
Open this post in threaded view
|

Re: FEATool won't solve

Precise Simulation
Administrator
Thank you for trying FEATool and taking the time to submit an issue report. Please try the following steps below to narrow down the issue:

1) Please confirm that you are using the latest version and build of FEATool which currently is 1.11.1 Build 19.11.332 (select About FEATool from the Help menu to find your current version and compare with the latest releases which always are available from the FEATool Multiphysics GitHub Repository).

2) Can you clarify wether you only have this issue for the "Fluid Dynamics > Flow in Driven Cavity" tutorial example model, or the Fluid-Structure Interaction (FSI) model (as the driven cavity model is does not involve FSI but is a standard laminar single phase flow CFD model)?

3) Does any of the other tutorial models solve and work as expected?

4) Does following the step-by-step tutorials, such as Tutorial Instructions for Flow in Driven Cavity, work?

If none of this helps or works please if possible also submit:

- FEATool Multiphysics version and build number.
- MATLAB version and operating system.
- Other relevant information about the system you are running on.


jhelffrich wrote
I first tried one of the FSI examples of fluid flow called "Flow in a driven cavity" that gave an error while running through the script.  When I click the Solve button, nothing happens but I get a warning in the Matlab UI saying "Warning: No or incompatible solution found. Applying initial conditions.
Error using featool
Could not find unique uicontrol with identifier button_post_settings
Caused by:
    Error executing UI action:
    ["uicontrol","button_post_settings",{},"Callback",{}]
Error while evaluating DestroyedObject Callback."